Is my Apple TV compatible for the FYC app?

The FYC app is currently compatible with 4th Generation Apple TV's and newer (4k)

Need help confirming what version Apple TV you own?

Visit the Apple Support page: Identify your Apple TV Model 

A quick way to determine if your device is compatible is to confirm the color of your Apple TV remote.  If your Apple TV remote is black, it is 4th Gen and able to support the FYC app. 

Please note: If your Apple TV remote is sliver, your device is unfortunately unable to support the FYC app. Please refer to our additional support articles outlining our "streaming" options (Chromecast, Roku, HDMI) for assistance.

How to download the FYC app on Apple TV

  • 130
  • 14-Dec-2019
  • 429 Views